安装 psycopg2 的问题:pg_config executable not found

使用 pip install psycopg2,特么报错,Error: pg_config executable not found。

网上搜索下,说需要安装 pg 和 py 的驱动:
Debian系:

apt-get install libpq-dev python-dev

RedHat系:

yum install libpqxx-devel python-devel

安装完成,再使用 pip install psycopg2,OK,一切顺利。

有的时候 pip 还经常出现 timeout,不省心啊!可以下载后安装:

Code example:

1

2

3

4

5


$ wget https://pypi.python.org/packages/source/p/psycopg2/psycopg2-2.5.2.tar.gz

$ tar -zxvf psycopg2-2.5.2.tar.gz

$ cd psycopg2-2.5.2/

$ ~/venv/bin/python setup.py build #我使用的是虚拟环境

$ ~/venv/bin/python setup.py install

分类:编程 时间:2015-04-18 人气:115
本文关键词: Linux社区
分享到:

相关文章

iOS 开发

Android 开发

Python 开发

JAVA 开发

开发语言

PHP 开发

Ruby 开发

搜索

前端开发

数据库

开发工具

开放平台

Javascript 开发

.NET 开发

云计算

服务器

Copyright (C) codeweblog.com, All Rights Reserved.

CodeWeblog.com 版权所有 闽ICP备15018612号

processed in 0.042 (s). 10 q(s)